Support de cours Mapinfo Formation au logiciel SIG

Commentaires

Transcription

Support de cours Mapinfo Formation au logiciel SIG
Chapitre I -
Introduction
duction aux SIG et à Mapinfo
Chapitre II -
Calage d’une image raster
Support de cours
Mapinfo
(Extrait de 30 pages)
Formation au
logiciel S.I.G.
Mapinfo version 11.5
Chapitre III
Gestion des couches
Mapinfo
Ministère de l’Agriculture – C.F.P.P.A.
57 avenue Charles de Gaulle - B.P. 15
38261 La-Côte-Saint-André cedex
Tél. 04 74 20 44 66
Révision juin 2013
Antoine LENOËL
Contact : [email protected]
0
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Chapitre III - Gestion des couches dans Mapinfo
1°) Importation de la base de données GEOFLA DEPARTEMENTS
Pour commencer ce chapitre, on va utiliser la base de données Ign GEOFLA, qui décrit
l'ensemble des unités administratives de France métropolitaine et DOM : frontières,
régions, départements, arrondissements, cantons et communes.
Depuis le 1er janvier 2012, la base de données GEOFLA est téléchargeable gratuitement sur le
site de l’Ign et utilisable pour tous les usages, y compris commerciaux.
Ce téléchargement se fait, à l’adresse : http://professionnels.ign.fr/gratuit
GEOFLA se décline en deux versions :
- GEOFLA DEPARTEMENTS (qui s’arrête aux limites départementales) ;
- GEOFLA COMMUNES 1 (qui va jusqu’aux limites cantonales et communales).
On utilisera, dans les paragraphes qui suivent, GEOFLA DEPARTEMENTS : limites
départementales (France entière) en projection Lambert 93 ou en projection Lambert 2 étendu
ou en coordonnées géographiques WGS84, associées à quelques renseignements attributaires.
Cette base de données GEOFLA est fournie :
- soit au format « .MIF/.MID », format d’échange de données vectorielles, de Mapinfo.
- soit au format « Shapefile », format de données vectorielles du logiciel ArcGIS.
Ce format MIF/MID, très utilisés, correspond à des données vectorielles (jamais rasters),
que Mapinfo peut importer grâce au menu :
Table / Importer… choisir le dossier d:\Mapinfo\Geofla\Lamb93
.MIF
avec Table / Importer,
à partir d’un fichier…
.MIF
…on génère une table Mapinfo
.TAB
.TAB
1
GEOFLA COMMUNES est une base de données assez volumineuse, doublement compressée. Il sera
nécessaire de décompresser deux fois le fichier téléchargé (d’où l'extension .TAR.GZ).
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
49
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
L’importation se déroule, et Mapinfo génère les fichiers « classiques » :
-
.TAB : fichier décrivant la structure des données tabulaires (types de champs,…)
.DAT : données tabulaires
.MAP : informations géographiques décrivant les objets graphiques)
.ID : index relatif au fichier graphique (.MAP)
éventuellement .IND : index relatif aux données tabulaires (.DAT)

Importer, de la même façon, à partir du fichier LIMITE_ADMIN_L93.MIF, les limites de
régions, les limites départementales, les limites côtières et les frontières.

Ouvrir l'image raster de Colombe : menu Fichier / Ouvrir...
D:\Mapinfo\Tp2Couches\Raster\COLOMBE.TAB
et fermer la fenêtre intitulée « Colombe Carte » qui est apparue (avec la croix
)
Enfin, avec le menu Fenêtre / Carte créer une fenêtre carte avec les 3 « couches »
suivantes :
fichiers ".tab"
actuellement ouverts
On obtient la fenêtre carte ci dessous :
rappels :
- clic-droit / Afficher toute la couche…
Toutes les couches
- menu Carte / Options
 Conserver échelle courante
- menu Carte /Zoom
Echelle 1 : 10 000 000
50
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Le menu Fenêtre / Données permet de créer une fenêtre avec les données
attributaires de la table choisie :
table attributaire des départements
champs
enregistrements
On pourra réduire les fenêtres (sans pour autant les fermer !) avec le bouton
2°) Contrôle des couches
1. Couche « visible », « sélectionnable », « éditable »
Nous disposons à présent de trois « couches » :
- une couche image raster : le fonds topographique scanné et géoréférencé de Colombe
couche sur laquelle on a superposé :
- une couche vectorielle « DEPARTEMENT_L93 », avec les contours départementaux de la
France
- une couche vectorielle « LIMITE_ADMIN_L93 », avec les limites de régions, limites
frontalières, limites côtières.
Le menu Carte / Contrôle des Couches ou
permet de gérer les couches
La boite de dialogue "contrôle des couches" a été complètement réétudiée avec la version 10.0
jusqu’en version 9.5 incluse :
Couche Dessin
deux couches vecteur
une couche raster
à partir de la version 10.0 :
Nom de la fenêtre Carte
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
51
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Chaque couche est dotée d'une case à cocher et de 3 symboles :
- la case à cocher (à gauche de chaque couche) permet de choisir l'affichage ou le
non-affichage de la couche ;
noter qu'une couche particulière appelée "Couche Dessin" est obligatoirement visible.
-
2
activé, signifie que la couche est éditable , c’est à dire que l’on va pouvoir
créer de nouveaux objets vectoriels par numérisation, ou modifier les contours des objets
existants ou encore modifier le style selon lequel les objets existants ont été créés.
(couleur, épaisseur de trait, etc.) (voir chapitre suivant, consacré à la numérisation d’objets vectoriels).
activé, signifie que la couche est sélectionnable (= on pourra sélectionner
les objets vectoriels qui s’y trouvent ; on pourra aussi utiliser l’outil information et
étiqueter les objets)
activé signifie que l’ensemble de la couche est étiquetée
-
Remarquer que :
- une couche raster ne peut être ni éditable, ni sélectionnable, ni étiquetée ;
- le nom d’une couche raster est précédé d’un symbole qui évoque des pixels ;
- lorsqu’une couche vectorielle est éditable, elle devient de fait sélectionnable ;
- on ne peut pas avoir deux couches éditables en même temps ;
- une éventuelle astérisque située tout à fait à gauche d’une couche signifie que le zoom
actuel de la carte ne permet pas l’affichage de cette couche (changez l’échelle !).
2. Ordre des couches
menu Carte / Contrôle des Couches ou
Un glissement de souris d’une couche, vers le haut ou vers le bas, permet de
changer l’ordre des couches sur la fenêtre carte.
Par exemple, - régler l'échelle au 1 : 6 000 000 avec l'outil
- puis agrandir suffisamment la fenêtre Carte afin que toute la France soit visible
- puis centrer la carte dans la fenêtre avec l’outil
- puis amener la couche « Colombe » en haut :
 l’image raster réapparaît à l’écran : elle était masquée précédemment
sous la couche des départements.
2
52
Avant la version 10.0 de Mapinfo, on parlait de couche « modifiable », au lieu de « éditable »
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Les boutons

Chap. 3 Gestion des couches
juin 2013
permettent :
- d’ajouter une couche dans la limite des tables qui ont été préalablement
ouvertes avec le menu Fichier/Ouvrir…
- d’enlever une couche de la carte (sans pour autant fermer le fichier .TAB qui reste ouvert !).
Par exemple, enlever la couche des limites administratives (côtières , frontalières,
régionales, etc.) avec le bouton
3. Liste des tables ouvertes
Depuis la version 8.5 de Mapinfo, le menu Table / Liste des Tables… permet
de connaître la liste des tables , dans la limites de celles qui ont été ouvertes avec l’outil
dans Mapinfo, il importe de
bien faire la distinction entre :
- table ouverte
et
- couche utilisée dans le
contrôle des couches.
Par exemple, une table peut être
ouverte mais non « valorisée » en
tant que couche dans une fenêtre
carte
Depuis la version 10.5 de Mapinfo, cette liste des tables s’est encore améliorée :
Par un double-clic sur
l’intitulé de cette fenêtre…
« liste des tables »,
on intègre cette liste à
gauche de l’écran, à la
place du…
« Contrôle des Couches »
(Voir les deux onglets en
bas d’écran)
En cliquant sur l’onglet, on passe
facilement du contrôle des couches à
la liste des tables, et inversement
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
53
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Trois types de tables dans Mapinfo :
- « Natives » : ce sont les tables
vectorielles contenant des
polylignes, des points, des
polygones.
- « Raster » : par exemple SCAN25
ou orthophotos
- « Requêtes » : qui résultent de
sélections (à la souris ou par requête
SQL).
Ce bouton permet de trier
Les tables par type
Le menu contextuel (clic-droit) à partir de l’une des tables de la liste, permet
d’accéder rapidement à plusieurs commandes fréquemment utilisées :
Par exemple, afficher le tableau de données
(c'est-à-dire la table attributaire)
… et d’autres commandes que l’on étudiera
par la suite !
Depuis les versions 11.0 et surtout 11.5 de Mapinfo, il est facile d’effectuer un tri des
enregistrements de la table :
clic (droit) sur le nom d'un champ
puis choisir l’ordre du tri
ou choisir un Filtre
par ex. uniquement les départements
de la région AUVERGNE
En immobilisant la souris sur l’une des tables, le chemin d’accès complet s’affiche :
54
Cette indication de chemin d’accès
Windows des différentes tables est très
utile pour aider à localiser sur l’ordinateur
les différentes sources de données qui
« alimentent » le document (.WOR) en cours.
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Le bouton « Auto Hide » en haut à droite de la « Liste des Tables » (ou du « Contrôle des Couches »)
va permettre de réduire la place occupée, à l’écran, par cette liste des tables (ou par le
« contrôle des couches »)
En cliquant sur l’un des
onglets, la liste des tables
(ou le contrôle des
couches) réapparaîtra ;
Il disparaîtra
automatiquement de
l’écran (« Auto Hide ») dès
qu’on travaille sur l’une
des fenêtres…
ce n’est pas forcément très
pratique à l’usage…
L’outil « Rechercher une table » permettra d’effectuer un filtrage sur le nom des tables
pour aider à retrouver plus facilement une (ou plusieurs) table(s).
Cela s’avérera utile lorsqu’on aura beaucoup de tables ouvertes.
On réduit ici l’affichage de
la liste à la (ou les) table(s)
commençant par LIM
Enfin, un cliquer/glisser de la liste des tables vers la fenêtre carte ajoutera à cette
fenêtre carte la ou les tables sélectionnées.
En faisant glisser la
table LIMITE-ADMIN_L93
vers la fenêtre carte, on
rajoute la couche avec
les limites (côtières,
frontalières, régionales,
etc.)
On ferait la même chose, à partir du « Contrôle des Couches », avec le bouton
,
mais cette solution du cliquer-déplacer à partir de la liste des tables est très efficace !
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
55
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
4. La couche Dessin
La couche dessin est la couche supérieure d’une fenêtre carte ; elle permet uniquement
de dessiner, sans pour autant créer de l’information dans une table attributaire.
Par exemple, on va dessiner un rectangle bleu autour de l’image raster de « Colombe »,
ce qui permettra de localiser rapidement
cette commune même lorsque la carte
est affichée à petite échelle ; pour cela,
- rendre la Couche Dessin « éditable » :
- zoomer sur la carte topographique de Colombe : menu Carte / Afficher toute
la couche ; choisir Colombe. Le fond topographique de Colombe doit occuper
toute la fenêtre carte (si nécessaire, remonter Colombe dans l’ordre des couches).
- avec l’outil rectangle
dessiner un rectangle
autour de cette image raster :
- pour que ce rectangle apparaisse avec une bordure bleue, il faut en changer le style
d’affichage : revenir à l'outil de sélection
et double-clic sur ce rectangle, puis :
Aucune
trame
Contour
bleu (I1)
Epaisseur
2 pixels
Résultat : même à très petite échelle, on repère facilement la commune de Colombe ;
penser à désélectionner le rectangle bleu avec l'outil

56
En principe, les objets créés dans la couche dessin ne sont pas conservés dans une table (.TAB) à moins que l’on choisisse
explicitement de le faire, avec le menu Carte / Enregistrer couche dessin).
En revanche ces « graphismes » seront conservés dans le document .WOR : il font partie de la « mise en valeur » des données
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
5. Modification des caractéristiques d’affichage
A partir du « Contrôle des Couches »,
pour accéder à la boite de dialogue « Propriétés de la couche… », on peut :
- soit faire un double-clic sur la couche (par exemple DEPARTEMENT_L93)
- soit faire un clic-droit sur la couche (par exemple DEPARTEMENT_L93) / Propriétés de la couche...
puis cocher  Modifier Style ;  le bouton de choix du style d'affichage devient actif :
lorsqu’on coche :  Modifier Style
on choisit un style différent de celui qui a été
choisi lors de la numérisation des objets de cette
couche
Trame N, pour « Neutre » :
 la couche des départements
devient transparente
De la même façon, on pourra modifier le style d’affichage des objets « points » et des
objets « lignes ou polylignes ».
Les couleurs, lignes et trames proposées par Mapinfo sont détaillées page suivante.
Elles n’ont pas évolué entre la version 7.5 et la version 11.0
Il n’est pas possible de créer de nouvelles trames de remplissage ;
En revanche, il est possible de créer :
- de nouveaux styles de lignes (utiliser l’outil « Mapinfo Line Style Editor », livré
avec Mapinfo versions 8.0 à 9.5 incluse : voir icône sur le bureau Windows).
En versions 10.x et 11.0, cet outil de création de lignes personnalisées ne semble plus exister.
- de nouveaux styles de points :
 Le nouveau symbole doit être dessiné au format « bitmap ». Utiliser par exemple
Windows « Paint » ; il doit avoir les mêmes dimensions en x et en y et être de type
« Bitmap 256 couleurs .BMP »
 Il doit obligatoirement être créé dans le dossier :
windows XP
windows 7
C:\PROGRAM FILES\MAPINFO\PROFESSIONAL\ADDUSER\CUSTSYMB
C:\UTILISATEURS\nom de connexion\APPDATA\ROAMING\MAPINFO\MAPINFO\PROFESSIONNAL\1100\CUSTSYMB
 Il faut ensuite relancer Mapinfo ;
 Enfin, dans le menu Options / Styles de symboles, choisir la Police « Symboles
personnalisés » puis cliquer sur le bouton Recharger ; le(s) symbole(s)
personnalisé(s) créé(s) doivent apparaître.
Pour plus de précisions, consulter l’aide de Mapinfo 11.0 (menu Aide / Contenu onglet Rechercher) et
faire une recherche sur « Utilisation de symboles personnalisés ».
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
57
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
6. Grilles des couleurs, des lignes et des trames de Mapinfo 11.5
Pas ou peu d’évolution depuis la version 7.5
Palette de couleurs :
Couleurs personnalisées :
création de
couleurs
personnalisées
(synthèse additive à
partir du Rouge, du
Vert et du Bleu)
Trames de remplissage :
En ligne 17, apparaissent les éventuelles couleurs personnalisées
Types de lignes :
L’épaisseur des
lignes s’exprime
soit en pixels,
soit en points
58
les trames E22
à G23 sont
apparues avec
la version 11.5
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Afin de disposer de davantage de données, ouvrir 5 tables supplémentaires situées dans
le dossier D:\MAPINFO\FRANCE_L93
Menu Fichier / Ouvrir …
Utiliser la touche Ctrl
pour ouvrir plusieurs
tables à la fois
en choisissant
« Ajouter à la
fenêtre carte
courante »
vous éviterez la
création d’une
autre fenêtre carte !
Régler l’échelle au 1 : 6 000 000 (1 cm représente 60 km)et agrandir la fenêtre carte en
conséquence.
Les nouvelles tables ouvertes figurent dans le Contrôle des couches
toutes visibles et sélectionnables :
; elles sont
Remarquer que les
dernières tables
ouvertes se
retrouvent « en haut »
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
59
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Depuis la version 10.0, le style d’affichage choisi, apparaît dans le contrôle des couches :
par un simple-clic sur le
symbole, on pourra modifier
le style d’affichage de chaque
couche
C’est un raccourci utile vers la
boite de dialogue
« Propriétés de la Couche… /
 Modifier Style »
Remarque :
Pour la couche Fleuves1, on a le
symbole ligne et le symbole
surface car cette couche contient
à la fois des objets « polylignes »
et des objets « polygones »
colonne G ; ligne 11
du tableau des couleurs
(voir page précédente)
Raccourci !
un clic sur le
symbole situé à
gauche du nom
de couche envoie
directement sur
 Modifier Style
Affecter aux différentes couches les styles suivants :
- décocher l’affichage de la couche LIMITE_ADMIN_L93
- mettre les départements en trame neutre, trait de contour épaisseur 1 pixel, couleur vert (G11)
- mettre les régions en trame neutre, trait de contour épaisseur 2 pixels, couleur bordeaux (K1)
et déplacer ces régions en couche supérieure.
- mettre les villes en symbole « disque plein », taille 6, couleur « jaune orangé » (E4)
- mettre les routes avec un style uniforme de trait épaisseur 1 pixel, couleur « orange » (E5)
- mettre les grands fleuves (Fleuves1) avec - les polylignes en bleu (K12) ;
- les polygones avec un remplissage bleu clair (K9) et
un contour bleu (K12)
- laisser inchangé les styles des objets de la couche de l’hydrographie plus détaillée (Fleuves2),
c'est-à-dire conserver le style choisi lors de la numérisation des objets.
Depuis la version 10.5, il est possible de définir des styles superposés.
Par exemple, couches des Routes on pourrait construire un type de lignes qui soit la
superposition
- d’un trait orange (E8) de 2 pixels d’épaisseur,
- par-dessus un trait marron (D13) de 3 pixels d’épaisseur
ainsi les routes apparaîtront sous forme de traits oranges, avec un discret liseré marron…
Clic-droit sur la couche Routes / Propriétés de la couche
60
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
7. Groupe de couches
Il s’agit de regrouper plusieurs couches (généralement associées à la même thématique),
afin de les gérer comme une seule entrée dans le contrôle des couches.
Par exemple, regrouper les deux couches de fleuves, dans un groupe de couches "Hydrographie"
Pour créer un groupe de couches,
Clic-droit dans le contrôle des couches sur le nom de la carte / Ajouter un groupe
 le nouveau groupe s’affiche ; il faut lui donner un nom : clic-droit/Renommer Hydrographie.
L’intitulé du groupe de couche existe ; reste à placer des couches à l’intérieur :
- soit par un clic-droit sur le groupe de couche / Ajouter des couches
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
61
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
- soit par un cliquer/déplacer de couches déjà présentes dans le contrôle des couches
Exemple : on pourra créer un autre groupe de couches appelé « Occupation du sol » dans
lequel on mettra les sources de données suivantes (situées dans le dossier
D :\MAPINFO\FRANCE_L93)
 Contours des zones bâties: BATI.TAB
 Contours des zones boisées: VEGETATION.TAB
62
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
8. Barre d’échelle
Depuis la version 10.0 de Mapinfo, on dispose, dans la barre « Général », d’un outil
permettant de dessiner une barre d’échelle dans la fenêtre carte.
Partir de la fenêtre carte et régler l’échelle au 1 : 6 000 000 (1 cm représente 60 km).
Activer l’outil
 un assistant permet d’abord de choisir la position de la barre d’échelle dans la fenêtre carte :
puis de paramétrer la taille et l’aspect de cette barre d’échelle
renseigner :
- soit la longueur de la barre
- soit la « distance terrain »
4 présentations
sont disponibles
 résultat : la barre d’échelle apparaît dans la fenêtre carte, à la position choisie :
Cette barre d’échelle est
dynamique : si on change l’échelle
de la carte, la barre d’échelle est
modifiée en conséquence.
On peut changer le paramétrage
par un clic-droit/propriétés dans la
barre d’échelle (ou un double clic)
On peut supprimer la barre
d’échelle par un clic-droit/supprimer
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
63
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
9. Seuils de Zoom
Pour l’instant, la carte est beaucoup trop chargée (surtout à petite échelle : essayer un
affichage au 1 : 10 000 000…).
La notion de « seuil de zoom » permet d’afficher une couche uniquement lorsque l’échelle
de la carte est comprise entre des valeurs déterminées.
Par exemple, lorsqu’on zoome notre carte en « France entière », les points jaunes
figurant les villes se chevauchent et le permettent plus de distinguer les villes.
Pour fixer un seuil de zoom, il faut :
- clic-droit sur la couche choisie (VILLES) choisir Propriétés de la Couche…
l’onglet « Affichage des couches » apparaît.
- cocher la case « Utiliser les seuils de zoom » et renseigner « Zoom Mini » et « Zoom Maxi ».
 conseil : pour vous aider à
déterminer les « bons » seuils
de zoom, faites afficher le
« Zoom » en barre d’état
(en bas gauche de l’écran).
 résultat : selon le zoom de la carte, les villes s’affichent… ou ne s’affichent pas
On pourra appliquer les seuils de zoom suivants :
Vérifier que l’unité de distance de la carte est le
kilomètre !
(menu Carte /
Options…)
-
Régions
Pas de seuils de zoom
Zoom mini 0
Villes
Zoom mini 0
Fleuves1 (principaux fleuves)
Zoom mini 100 km
Fleuves2(réseau hydro. plus détaillé) Zoom mini 0
Routes
Zoom mini 0
Bati
Zoom mini 0
Végétation
Zoom mini 0
DEPARTEMENT_L93
Une valeur élevée
de zoom (= largeur
de fenêtre carte)
Zoom maxi 2 000 km signifie affichage à
Zoom maxi 1 000 km petite échelle
Zoom maxi
Zoom maxi
Zoom maxi
Zoom maxi
Zoom maxi
600
100
300
100
200
km
km
km
km
km
 voir le résultat obtenu : partir de l’échelle 1 : 20 000 000 puis, en faisant varier le zoom
(roulette de la souris), certaines informations apparaissent, d’autres disparaissent.
Lorsqu’on est en dehors de
la plage de Zoom, la couche
disparaît, le nom de la
couche devient grisé et une
astérisque apparaît à
gauche de la couche.
64
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
10. Styles par Zoom
Depuis la version 10.5 de Mapinfo, il est possible de créer des « Styles par Zoom »
qui permettent de faire varier le style d’affichage des objets en fonction du zoom de la
fenêtre carte.
Il s’agit, par exemple, de faire afficher une couche avec des symboles plus petits ou plus
fins lorsque la carte est à petite échelle (Zoom élevé) ; symboles plus gros à grande
échelle (Zoom faible)
C’est un prolongement de la notion de « Seuils de zoom », vue page précédente.
Considérons la couche Villes de la carte précédente ; pour l’instant, on a affecté un
symbole taille 6 pour un zoom de 0 à 1 000 km.
Clic-droit sur la couche Villes / Ajouter un remplacement de style de couches
 une « tranche » de zoom apparaît, de 0 à 1 000 km ; on va la scinder :
Clic-droit sur la « tranche » 0 à 1 000 km / Découper
 la « tranche » 0 à 1 000 km est scindée en deux tranches égales : de 0 à 500 km et de
500 à 1 000 km
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
65
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
On va pouvoir affecter des styles différents à chaque « tranche » de Zoom :
Clic-droit sur une « tranche » de Zoom / Afficher les propriétés de remplacement
Ou, plus simplement, double-clic sur une « tranche » de Zoom
Entre 0 et 250 km, taille 9
Un symbole plus gros
lorsqu’on est à plus grande
échelle
Laisser le symbole « taille 6 » pour la « tranche » de Zoom de 250 à 1 000 km (un
caractère plus petit lorsqu’on est à plus petite échelle).
Exemple : on pourra appliquer cette notion de « Styles par Zoom » à la couche des
Routes, pour obtenir un trait assez fin à petite échelle et plus épais à grande échelle
66
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
11. Etiquetage
Ne conserver visibles que les couches Départements, Régions et Villes
Et régler l’échelle au 1 : 2 000 000 (1 cm représente 20 km)
On souhaite maintenant faire afficher le nom de la région sur la carte.
d’où menu Carte / Contrôle des Couches ou
 Cocher la colonne
« Etiquette »de la
couche à étiqueter
Puis il va falloir paramétrer l’étiquette par un
clic-droit sur la couche à étiqueter / Propriétés de la couche…
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
67
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Dans l’onglet « Affichage des étiquettes », choisir le champ qui « pilote » l’étiquette :
 Choisir le champ qui servira à
étiqueter
(Par défaut, c’est le premier de la
table attributaire)
 Choisir la police, la taille, la
couleur (ici, bordeaux, K1), le
style de l’étiquette
Exercice : étiqueter, de la même façon, les départements avec les intitulés de départements.
Lorsqu’on diminue l’échelle (par exemple au 1 : 6 000 000), certaines étiquettes n’ont plus la
place d’être affichées et disparaissent !
 on peut réduire la taille des caractères des étiquettes dans « Styles »
 on peut aussi « autoriser le chevauchement » des étiquettes :
onglet « Règles d’étiquetage », cocher « Autoriser le chevauchement » :
68
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Remarques :
 Il est possible d’étiqueter à partir d’une « expression », c'est-à-dire une
« combinaison » de plusieurs champs, de zones de texte, etc.
Réfère au champ
intitulé PSDC (c’est à
Taper 1 ou 2 ou 3
espaces à l’intérieur
des guillemets
dire « population sans
double-compte ») de la
table des régions
 La notion de « seuils de zoom » est applicable aux étiquettes (c'est-à-dire affichage
des étiquettes uniquement lorsqu’on est dans une certaine plage de zoom) onglet
« Règles d’étiquetage », « utiliser les seuils de zoom »
Par exemple, pour la couche Régions, étiquettes affichées dans la plage 0 à 2 000 km ;
De même, depuis la version 10.5, la notion d’étiquettes de remplacement permettra de
faire varier le style d’affichage des étiquettes en fonction du Zoom (taille plus petite à
Zoom élevé) : clic-droit sur la couche / Ajouter un remplacement des paramètres d’étiquetage
 On peut déplacer une étiquette (par glissement de souris avec l’outil
) : elle
devient alors « Etiquette Personnalisée » ou étiquette « manuelle » ;
de la même façon, on peut « éditer » une étiquette (=la modifier) par un double-clic
avec l’outil
faire un double-clic sur une
étiquette pour la modifier
 elle devient « étiquette manuelle »
par exemple,
l’étiquette RhôneAlpes en rouge
 Au lieu d’étiqueter l’ensemble des objets d’une couche, on peut aussi n’étiqueter que
tel ou tel objet avec l’outil
; là aussi, il s’agit d’étiquettes « manuelles ».
Exemple : sur la couche des villes, étiqueter uniquement les communes de Grenoble, La Tourdu-Pin et Vienne (commencer par choisir le champ qui « pilote » l’étiquette : nom de la ville !)
Pour revenir aux étiquettes « automatiques », c’est à dire gérées par Mapinfo,
menu Carte / Effacer Etiquetage personnalisé
Exercices :
SAVOIE
Etiqueter
les
Départements
de
la
façon
suivante
:
(Chambéry) et en vert (G11)
On pourra s’inspirer
des exemples donnés
Bordeaux (K1)
- Etiqueter les Régions de la façon suivante : AUVERGNE
dans
(1 308 654 h.)
l’Aide Mapinfo :
menu Aide / Contenu
onglet Index
choisir « étiquettes »
puis « création à l’aide
d’expressions »
Bleu (I1)
…probablement faudra-t-il charger la couche des régions deux fois…
On trouve la liste complète des fonctions Mapinfo dans le menu Aide/Contenu
onglet Index… Fonction liste des fonctions par ordre alphabétique
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
69
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
3°) Outils de sélection à l’écran
1. Préliminaires
Mapinfo dispose de plusieurs commandes pour réaliser des sélections ; on peut les
classer en deux catégories :
- les sélections directes à partir de l’écran, à l’aide des outils
et des menus Sélection / Tout Sélectionner et Sélection / Tout Désélectionner
- les sélections à l’aide de requêtes : menus Sélection/Sélection et
Sélection/Sélection SQL : il s’agit de créer une expression logique que Mapinfo
utilise pour extraire le(s) enregistrement(s) répondant à certains critères : par exemple
surface> 1000 ha et Population > 800 habitants.
A chaque fois qu’on réalise une sélection, MapInfo crée une table temporaire pour y
stocker les enregistrements sélectionnés
Configurer les couches de la façon suivante :
vérifier que la couche dessin n’est
pas sélectionnable !
3 couches
vectorielles
« sélectionnables »
régions
départements
Principales villes
fond scanné commune de Colombe
aucune sélection possible sur
une couche « raster »
Régler le Zoom au 1 :4 000 000, de façon à visualiser plusieurs régions :
On pourra visualiser la table attributaire des départements :
menu Fenêtre/Données basé sur DEPARTEMENT_L93
Rappel : depuis la version 10.5,
à partir de la « Liste des Tables »,
Clic-droit sur la couche des Départements
Afficher tableau de données
table attributaire des départements DEPARTEMENT_L93
70
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
2. L’outil de sélection
Pour pouvoir sélectionner des objets à l’écran, la couche qui contient ces objets doit être
« sélectionnable » : menu Carte/Contrôle des Couches
3 couches
sélectionnables
Si une fenêtre Carte contient plusieurs couches sélectionnables (il y en a 3 sur notre
exemple), MapInfo sélectionne les objets dans la couche supérieure.
En utilisant <Ctrl>
, on va pouvoir sélectionner des objets qui ne se trouvent pas
dans la couche supérieure. Exemple : sélectionner le département de l’Isère
En utilisant la touche <Shift>
, on va pouvoir sélectionner plusieurs objets à la fois.
La sélection d’objets dans une fenêtre Carte entraîne la sélection des mêmes objets dans
la fenêtre Données, et inversement :
<Ctrl>  Sélection d’objets situés dans une couche « en dessous »
<Shift>  Sélection de plusieurs objets (de la même couche)
Les sélections se font indifféremment à
partir de la fenêtre Carte et/ou à partir
de la fenêtre Données
(clic dans la marge à gauche de
l’enregistrement)
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
71
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Les boutons
du Contrôle des Couches permettent de modifier l’ordre des
couches et donc de pouvoir sélectionner directement telle ou telle couche d’information,
sans avoir à utiliser <Ctrl>
Dans cette configuration, on
sélectionnera d’abord des
départements et éventuellement
des régions ou des villes en
utilisant la couche <Ctrl>
3. Inverser la sélection
L’outil
permet d’inverser la sélection : sur l’exemple de la page précédente, il
s’agirait de sélectionner tous les départements SAUF les quatre départements préalablement
sélectionnés.
4. Tout désélectionner
Il suffit de cliquer sur l’outil
pour tout désélectionner
Cet outil est utilisable à partir d’une fenêtre carte ou d’une fenêtre de données.
5. Outil de sélection par rectangle
l’outil
permet de sélectionner tous les objets dont le centroïde se trouve à l’intérieur
d’un rectangle, qui est matérialisé par glissement de souris d’un coin supérieur gauche
vers un coin inférieur droit.
Le « centroïde » désigne le centre ou milieu d’un objet cartographique ; il est situé à michemin entre les extrémités nord et sud et à mi-chemin entre les extrémités est et ouest.
Le centroïde est toujours situé à l’intérieur de l’objet ; ainsi, dans le cas d’un objet
polygonal en forme de croissant, le point central peut être en dehors de limites du
polygone, alors que le centroïde sera situé à l’intérieur des limites du polygone.
centre
centroïde
centroïde
Le centroïde, au sens MapInfo, n’est pas le centre de gravité de l’objet ; par exemple :
centroïde
72
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Il est possible de faire afficher les « centroïdes » : dans les Propriétés de la couche
(DEPARTEMENT_L93, par exemple), cocher  Afficher les centroïdes
les centroïdes
apparaissent sous la
forme de points bleus ;
ils se trouvent toujours
à l’intérieur de l’objet ;
Remarquer que les
étiquettes sont, par
défaut, positionnées sur
le centroïde
Pour sélectionner avec l’outil
étendre un rectangle de sélection incluant les
centroïdes des objets à sélectionner :
glissement de souris
matérialisant un rectangle
de sélection
 seuls les objets dont
le centroïde est inclus
dans ce rectangle, sont
sélectionnés
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
73
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
6. Outil de sélection par distance
L’outil
permet de sélectionner tous les objets dont le centroïde se trouve à l’intérieur
d’un cercle de sélection, qui est dessiné par glissement de souris à partir du centre du cercle.
glissement de souris
matérialisant un cercle
de sélection
 seuls les objets
dont le centroïde est
inclus dans ce cercle,
sont sélectionnés
Permet de sélectionner tous les objets qui se trouvent dans un rayon donné.
Exemple : quelles sont les villes situées dans un rayon de 100 km autour de Vienne (en Isère).
 Utiliser le menu Sélection / Rechercher (<Ctrl> F) pour trouver « Vienne » dans la table des communes
7. Outil de sélection par forme libre
L’outil
permet de sélectionner tous les objets dont le centroïde se trouve à
l’intérieur d’une forme dessinée à la souris :
dessin d’une forme
libre, à la souris ;
tous les objets dont
les centroïdes sont
situés à l’intérieur
de cette figure, sont
sélectionnés
Exemple : sélectionner, par cette méthode, les villes de Savoie et Haute-Savoie
74
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
8. Outil de sélection par polygone
L’outil
permet de sélectionner le(s) objet(s) situés à l’intérieur d’un polygone
(Attention ! ne le confondez pas avec l’outil précédent de sélection par "forme libre")
Exemple 1 : sélectionner (en un clic souris) toutes les villes de l’Isère (c'est-à-dire
inclues dans le polygone Isère)
Sélectionner, ensuite, les villes de Savoie et celles de Haute-Savoie (en 2 clic-souris !).
Exemple 2 : sélectionner, en un clic souris, toutes les villes de la région Rhône-Alpes.
Exemple 3a : sélectionner, en un clic souris, tous les départements de Rhône-Alpes :
8 entités « départements » sélectionnées
Ce n’est pas la même chose que de sélectionner la
région Rhône-Alpes (1 entité « Région »
él
ti
é )
Exemple 3b : sélectionner tous les départements des régions Rhône-Alpes et Auvergne.
Exemple 4 : sélectionner (en un clic souris) tout le réseau routier situé sur le
département de l’Isère.
 cette fois-ci, le résultat n’est pas satisfaisant : on sélectionne des routes qui
« dépassent » dans les départements limitrophes !
Explication : la structure géométrique des routes « ignore » les limites départementales
car lorsque ce réseau routier a été numérisé, l’opérateur n’a évidemment pas tenu compte
des limites départementales. Il faudra donc faire subir aux routes un traitement spatial de
découpage en fonction des limites de départements (on étudiera ça plus tard).
Puis la sélection « par polygone » donnera les résultats escomptés.
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
75
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
4°) Le menu Sélection / Statistiques
Pour illustrer ce paragraphe, utiliser la sélection par polygone
les villes de la région Rhône-Alpes :
pour sélectionner
On va travailler sur une sélection des communes « de l’Isère » (= en excluant les limitrophes)
Utiliser l’outil de sélection par polygone
et cliquer n’importe où dans le polygone « Isère »
(Remarque : penser à rendre la couche dessin « non sélectionnable » car sinon on sélectionnerait
le carré bleu situé dans la couche dessin !)
Dès lors,
 on peut ouvrir une fenêtre de données basée sur cette sélection :
menu Fenêtre / Données
La fenêtre de données qui apparaît s’appelle « Query1 » : c’est un nom générique
attribué par Mapinfo lorsqu’on fait une sélection de données :
Si l’on ouvre d’autres fenêtres
de données basées sur des
sélections, celles ci
s’appelleront Query2 puis
Query3, etc.
76
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Cette table contient 198 enregistrements (voir en bas à gauche, sur la barre d’état Mapinfo).
 on peut charger cette couche de sélection « Query1 » dans le contrôle des couches :
outil
Attention ! les sélections faites « à la
souris » ne pourront évidemment pas être
« mémorisées » dans le document .WOR
En d’autres termes, si des couches Query1,
Query2, etc. ont été chargées dans le
Contrôle des Couches, elles n’apparaîtront
plus lors de la réouverture ultérieure du
.WOR !
On pourra affecter un style particulier à ces villes de Rhône-Alpes ; disque taille 7 orange (D9)
 on peut faire un certain nombre de statistiques sur les champs numériques de cette sélection :
menu Sélection / Statistiques
Choisir la table


on obtient les statistiques sur le champ PSDC :
- soit parmi les fichiers .tab ouverts
- soit parmi les sélections déjà faites
(Selection ou Query1, Query2, Query3…)
Choisir , parmi les champs
numériques, le champ sur lequel on
fera les statistiques
(sur cet exemple, la table des villes ne présente
qu’un seul champ numérique : PSDC)
On a le nombre de valeurs
(198) et des indicateurs
statistiques sur le champ
PSDC : minimum, maximum,
étendue, moyenne, écart-type,
etc.
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66
77
Cfppa La-Côte-St-André
Antoine LENOËL
Formation Mapinfo
Chap. 3 Gestion des couches
juin 2013
Remarque : lorsqu’on appelle le menu Sélection / Statistiques,
dans la liste déroulante "Tables", Mapinfo ignore les tables qui n’auraient pas de champ
numérique (par exemple Fleuves1, Fleuves2, etc.).
Pour obtenir des statistiques, on peut aussi utiliser l’outil « Afficher/Cacher statistiques »
A partir d’une sélection en cours, cet outil fournit, pour chacun des champs
numériques, un tableau avec la somme et la moyenne :
Par exemple, statistiques sur les Régions
sur cet exemple, on a sélectionné
toutes les régions :
placer Regions en couche supérieure,
puis menu Sélection / Tout
sélectionner à partir de Régions
Autre exemple : afficher les statistiques de population pour les villes situées à
50 kilomètres à vol d’oiseau autour de Vienne ( 82 villes ; 1 719 441 hab.)
Remarque : Dans ce menu Sélection / Statistiques, il n’est pas possible de rentrer
une expression c’est à dire de construire un calcul, à partir d’un ou plusieurs champs.
exemples : POPULATION1999 – POPULATION1990 pour calculer un écart de population
SURFACE / 100
pour convertir les surfaces en km²
Seules les requêtes SQL permettront d’effectuer des statistiques portant sur des
expressions (voir Chapitre V).
78
Ministère de l’Agriculture C.F.P.P.A. – 57 av. Charles de Gaulle - 38260 La-Côte-St-André – Tél. 04 74 20 44 66