Utilisation de l`ordinateur dans la rédaction des rapports de laboratoire

Commentaires

Transcription

Utilisation de l`ordinateur dans la rédaction des rapports de laboratoire
Utilisation de l’ordinateur dans la
rédaction des rapports de laboratoire
Département de physique
Bruno Binet
Patrick Labrecque
Janvier 2006
TABLE DES MATIÈRES
COMMENCER UNE SESSION DE TRAVAIL AVEC EXCEL .....................................................1
POUR DÉMARRER L'ORDINATEUR EN WINDOWS 2000PRO OU WINDOWS XP .................................1
POUR DÉMARRER LE LOGICIEL MICROSOFT EXCEL ........................................................................1
POUR TERMINER VOTRE SESSION DE TRAVAIL AVEC L'ORDINATEUR ..............................................2
ACCÉDER AUX DOSSIERS DE VOTRE PROFESSEUR SUR LE RÉSEAU NOVELL..............2
NOM DU DOSSIER DE VOTRE PROFESSEUR ......................................................................................2
POUR DÉPOSER UNE COPIE DE VOTRE TRAVAIL DANS SON DOSSIER « RETOUR » ..........................3
POUR OUVRIR UN DOCUMENT À PARTIR DE SON DOSSIER « PUBLIC » ...........................................3
RÉCUPÉRER UN DOCUMENT SUR LA PAGE WEB DU DÉPARTEMENT ...........................4
UTILISATION DE L’IMPRIMANTE EN LABORATOIRE ..........................................................5
EST-CE QUE MON DOCUMENT SORTIRA SUR LA BONNE IMPRIMANTE? ............................................5
OÙ SONT LES POLICES DE CARACTÈRES (FONTS)? ..........................................................................5
COMMENT INSTALLER LE PILOTE DE L’IMPRIMANTE?.....................................................................5
QUE FAIRE LORSQU’IL MANQUE DE PAPIER?...................................................................................5
UTILISATION D’EXCEL DANS UN RAPPORT DE LABORATOIRE : UN EXEMPLE...........6
CONTEXTE .....................................................................................................................................6
SAISIE DES RÉSULTATS ...................................................................................................................6
PRODUCTION DU GRAPHIQUE PAR L’ASSISTANT GRAPHIQUE ..........................................................7
MISE EN FORME GÉNÉRALE DU GRAPHIQUE .................................................................................11
CORRECTION DU QUADRILLAGE DU GRAPHIQUE ...........................................................................12
AJOUT DES BARRES D’INCERTITUDES ...........................................................................................13
AJOUT DE LA COURBE DE TENDANCE ...........................................................................................14
IMPRESSION DU GRAPHIQUE DANS EXCEL ....................................................................................15
POINTS À SURVEILLER CONCERNANT LES GRAPHIQUES ...............................................17
PRÉSENTATION DE BASE ..............................................................................................................17
GRADUATIONS .............................................................................................................................17
COURBE DE TENDANCE (S’IL Y A LIEU).........................................................................................17
MARQUES D’INCERTITUDES (S’IL Y A LIEU) ..................................................................................17
i
MISE EN FORME DES TABLEAUX ...........................................................................................18
MISE EN FORME DANS EXCEL .......................................................................................................18
COPIER CORRECTEMENT UN TABLEAU OU UN GRAPHIQUE EXCEL DANS WORD ...........................19
EXEMPLE SUR LE CALCUL D'INCERTITUDE AVEC EXCEL ..............................................21
MISE EN SITUATION : ...................................................................................................................21
CALCUL D’UNE FONCTION MATHÉMATIQUE ..................................................................................21
CALCUL DE L'INCERTITUDE SUR UNE FONCTION ...........................................................................22
ÉCRITURE DES ÉQUATIONS AVEC MATHTYPE (DANS WORD).......................................23
TRUCS ET ASTUCES SUR WORD ET EXCEL .........................................................................25
COURBE DE TENDANCE PASSANT PAR (0,0)
DANS
EXCEL .............................................................25
PROLONGATION DE LA COURBE DE TENDANCE DANS EXCEL ........................................................25
TRAITEMENT DES PENTES EXTRÊMES AVEC EXCEL .....................................................................26
POINTS SINGULIERS :
QUOI FAIRE
?..............................................................................................29
LISSAGE DE COURBE.....................................................................................................................29
COMPARAISON DES RÉSULTATS ....................................................................................................32
SAUVEGARDE RÉGULIÈRE.............................................................................................................32
RECYCLAGE DES FICHIERS ...........................................................................................................32
ALPHABET GREC ET CARACTÈRES SPÉCIAUX DANS WORD ET EXCEL ..........................................33
ii
© Département de physique, Cégep de Sherbrooke, 2006
Commencer une session de travail avec Excel
Pour démarrer l'ordinateur en Windows 2000Pro ou Windows XP
1.
Ouvrez l'appareil et l'écran.
2.
Attendez…(soyez patient!)
3.
Lorsque la fenêtre Novell vous suggérant de lancer le « login » apparaît, appuyez
simultanément sur les trois touches Ctrl + Alt + Suppr (Suppr se nomme aussi Delete sur
certaines stations).
4.
À l'apparition de la fenêtre Client Novell pour Windows : entrez votre nom d’usager et votre
mot de passe. Cliquez sur OK pour continuer.
5.
Une deuxième fenêtre apparaîtra : Poste de travail Windows. Vérifiez que le nom est bel et
bien invite (si c'est pas le cas, faites les modifications nécessaires). Inscrivez le mot de passe :
cegep (sans accent) puis cliquez sur OK.
6.
Vous êtes maintenant rendu dans Windows 2000Pro (ou Windows XP Pro).
Pour démarrer le logiciel Microsoft Excel
Sous Windows 2000 :
Double-cliquez sur l'icône Excel directement
ou
avec la souris, allez dans le coin inférieur gauche et sélectionnez :
Démarrez
Programmes
MsOffice2000
Microsoft Excel
Sous Windows XP :
La suite Office (Word, Excel, Powerpoint…) est directement accessible dans le menu
Programmes.
Commencer une session de travail avec Excel
1
© Département de physique, Cégep de Sherbrooke, 2006
Pour terminer votre session de travail avec l'ordinateur
1.
Ne quittez jamais sans vous déconnecter du réseau. Ne fermez jamais l'ordinateur
physiquement sans suivre la procédure suivante :
2.
Sauvegardez tous vos documents.
3.
Fermez toutes vos applications (dans le menu Fichier : Quitter)
4.
Dans le menu Démarrez de Windows (2000Pro ou XP), en bas à gauche, allez sur Fermer la
session invité….
5.
Dans le fenêtre « êtes-vous sûr de vouloir vous déconnecter ? », cliquez sur oui.
Accéder aux dossiers de votre professeur sur le réseau Novell
Nom du dossier de votre professeur
Votre professeur possède un dossier accessible par réseau (sur les ordinateurs du cégep seulement).
Le nom de ce dossier dépend du nom de votre professeur. En voici les possibilités :
AUBEMA (Martin Aubé)
BINETBR (Bruno Binet)
BOLDUCJD (Julie Bolduc Duval)
DESCHAMA (Mathieu Deschamps)
FOURNIMC (Michel Fournier)
FRANCHLO (Loïc Franchomme Fossé)
GAUDREFR (François Gaudreau)
LABRECPA (Patrick Labrecque)
STMICHMA (Martin Saint-Michel)
STAMANLA (Laurier St-Amant)
THERIADE (Denis Thériault)
Accéder aux dossiers de votre professeur sur le réseau Novell
2
© Département de physique, Cégep de Sherbrooke, 2006
Pour déposer une copie de votre travail dans son dossier « Retour »
-
Enregistrez votre travail dans votre espace réseau (répertoire t:\)
-
Allez dans Démarrez / Programmes / Accessoire / Explorateur Windows. Une fenêtre
séparée en deux parties apparaîtra.
-
Dans la partie Tous les dossiers (située à gauche), cliquez sur le répertoire dans lequel se
trouve le fichier que vous voulez copier. Le contenu de ce réperoire devrait apparaître
dans la partie droite de la fenêtre.
-
Sur le bureau (desktop), il y a un raccourci nommé « Répertoires partagés ». Ouvrez ce
raccourci puis choisissez départements programmes / physique/ retour
-
Glissez votre document dans le dossier de votre professeur : Pour ce faire, cliquez sur
votre document, gardez le bouton de la souris enfoncé et faites glisser votre document
vers le dossier de votre professeur. Lorsque le répertoire de votre professeur s'illumine,
relâchez le bouton de la souris. Vous venez de copier votre fichier dans le dossier retour
de votre prof, bravo!
Pour ouvrir un document à partir de son dossier « Public »
Toujours à partir du raccourci « Répertoires partagés » qui se trouve sur le bureau,
choisissez départements programmes / physique/ public puis le répertoire de votre
professeur. Double-cliquez sur le fichier afin de l’ouvrir.
Accéder aux dossiers de votre professeur sur le réseau Novell
3
© Département de physique, Cégep de Sherbrooke, 2006
Récupérer un document sur la page web du département
Certains documents seront distribués par une page web qui offre l’avantage d’être accessible de
n’importe quel ordinateur au monde (!) muni d’une connexion internet. Dans un navigateur de
votre choix, allez à l’adresse suivante : www.cegepsherbrooke.qc.ca/~phy. Notez que le caractère
« ~ » est obtenu en tapant, sur un clavier français, « AltCar + ; ». Dans le menu à gauche,
sélectionnez « Documents à télécharger ». Par sa suite une nouvelle fenêtre s’ouvrira avec les
noms de tous les programmes dans lesquels le département de physique offre des cours. Vous
choisissez le programme dans lequel vous êtes inscrits, puis le cours et enfin le nom de votre
professeur. Pour revenir en arrière, vous cliquez sur « Parent Directory », ou encore le bouton à
cet effet dans le navigateur (« Précédente » dans Internet Explorer).
Plusieurs documents utiliseront le format « PDF » (Acrobat). L’application « Acobat Reader »,
nécessaire pour lire ces documents, est disponible gratuitement sur :
http://www.adobe.com/products/acrobat/readstep2.html
Récupérer un document sur la page web du département
4
© Département de physique, Cégep de Sherbrooke, 2006
Utilisation de l’imprimante en laboratoire
Est-ce que mon document sortira sur la bonne imprimante?
Dans le menu Fichier de Excel (ou d’un autre logiciel) choisissez imprimer. Choisissez alors le
nom de l’imprimante correspondant au local où elle se trouve (exemple 2-55-365). Cliquez sur
Fermer. Si jamais vous ne trouvez pas l’imprimante de votre laboratoire dans la liste proposée,
c’est que son pilote n’est pas installé. Il faut alors installer le pilote de l’imprimante du laboratoire
tel que mentionné ci-bas.
Où sont les polices de caractères (fonts)?
Si jamais la police du texte (font) à l’écran vous semble curieuse, il est fort possible que se soit
parce qu’aucun pilote d’imprimante n’est installé. Il faut alors installer le pilote de l’imprimante
du laboratoire tel que mentionné ci-bas.
Comment installer le pilote de l’imprimante?
Il faut alors aller dans la fenêtre « Applications fournies par Novell pour… ». Cette fenêtre est
toujours accessible. Dans cette fenêtre, double-cliquez sur l’icône Imprimantes-pav2 Lab. Ceci
installera les pilotes de toutes les imprimantes des laboratoires d’informatiques du pavillon 2. Il
faut faire cette procédure (une seule fois) à chaque fois que « l’image de base » de l’ordinateur est
réinitialisée par un « ghost ». L’image est le système d’exploitation Windows et les autres
logiciels installés sur le disque rigide local de l’ordinateur.
Que faire lorsqu’il manque de papier?
Si jamais il n’y a plus de papier dans l’imprimante au laboratoire D (local 2-54-185 près des
machines distributrices), il faut demander à un professeur de mathématiques car le papier se
trouve dans le petit bureau à l’intérieur du laboratoire. Si c’est au laboratoire E (local 2-55-365
face au laboratoire d’électricité), il faut demander aux secrétaires du secteur B (Colette Labrecque
et Francine Roy). Leurs bureaux se trouvent à l’intersection des corridors 7 et 2.
Utilisation de l’imprimante en laboratoire
5
© Département de physique, Cégep de Sherbrooke, 2006
Utilisation d’Excel dans un rapport de laboratoire : un exemple
Contexte
Les données de l’exemple 6.6 du Guide des sciences expérimentales de Boisclair et Pagé, 2e
édition, sont utilisées. L’objectif était d’obtenir expérimentalement la masse volumique de l’eau en
mesurant sa masse (incluant un récipient) en fonction de son volume. Si la masse volumique est
constante au cours de l’expérience, la relation entre la masse et le volume devrait être linéaire.
L’exemple est construit à l’aide d’Excel 2000 (9.0.2812). Pour vérifier la version du logiciel, cliquer
sur « À propos de… » dans le menu d’aide. Il n’y a pas de changement majeur dans Excel XP.
Saisie des résultats
Après une saisie brute des données dans Excel, le tableau ressemble à ceci :
•
Le symbole ± a été obtenu en maintenant enfoncée la touche « Alt Car » et en appuyant sur
1.
•
Une colonne spéciale (D ici) doit être prévue pour les symboles ±, afin qu’Excel traite les
informations de la colonne suivante (E ici) comme des valeurs numériques.
Utilisation d’Excel dans un rapport de laboratoire : un exemple
6
© Département de physique, Cégep de Sherbrooke, 2006
•
Attention aux nombres décimaux. Sur une configuration standard, il faut entrer la virgule et
non le point pour qu’Excel interprète ces nombres comme des valeurs numériques.
•
L’indice t et l’exposant 3 ont été obtenus en sélectionnant le caractère en question, puis en
cliquant le bouton droit de la souris et en choisissant « Format de cellule ». L’exposant 3
peut aussi s’obtenir directement en maintenant enfoncée la touche « Alt Car » et en
appuyant sur 9.
Production du graphique par l’assistant graphique
•
Cliquer sur le bouton de l’assistant graphique
.
Étape 1 sur 4
•
Choisir le type de graphique Nuage de points (sans courbe) et appuyer sur « Suivant ».
Utilisation d’Excel dans un rapport de laboratoire : un exemple
7
© Département de physique, Cégep de Sherbrooke, 2006
Étape 2 sur 4
•
Dans l’onglet « Plage de données », s’ assurer de sélectionner « Série en colonnes ».
•
Dans l’onglet « Série », cliquer sur « Ajouter » pour ajouter une série de données (ou
sélectionner une série dans la liste, s’il y en a déjà). Cliquer ensuite sur le bouton au bout de
la ligne « Valeurs X : ». La boîte de dialogue se condense, ce qui permet de sélectionner les
cellules C6 à C13. Il suffit de cliquer à nouveau sur le bouton pour afficher la boîte de
dialogue en entier. Procéder de la même façon pour les valeurs Y (cellules F6 à F13).
•
Note : Si on voulait placer plusieurs courbes sur le même graphique, il serait possible de
donner un nom à chacune dans cet onglet. Chaque courbe correspond à une série.
•
Un raccourci : Au lieu d’entrer les données X et Y manuellement, on aurait pu simplement les
sélectionner avant de lancer l’assistant graphique. Pour ce faire, il aurait fallu sélectionner les
cellules C6 à C13 et, en maintenant la touche CTRL enfoncée, sélectionner les cellules F6 à
F13. Excel comprend alors au moment de lancer l’assistant que la première colonne
correspond à l’axe des X et la seconde, à l’axe des Y.
•
Cliquer sur « Suivant ».
Utilisation d’Excel dans un rapport de laboratoire : un exemple
8
© Département de physique, Cégep de Sherbrooke, 2006
Étape 3 sur 4
•
Dans l’onglet « Titres », entrer un titre pour le graphique et pour les axes tel qu’illustré.
L’exposant 3 a été obtenu en maintenant enfoncée la touche Alt Car et en appuyant sur 9.
Toutefois, on ne peut pas mettre le « t » en indice dans cette boîte de dialogue (c’est possible
plus tard).
•
Dans l’onglet « Quadrillage », cocher les quatre cases afin d’obtenir un quadrillage principal
et secondaire pour les deux axes.
•
Dans l’onglet « Légende », supprimer la légende.
•
Cliquer sur « Suivant ».
Étape 4 sur 4
•
Pour cet exemple, insérer le graphique en tant que nouvelle feuille (mais toujours dans le
même document).
Utilisation d’Excel dans un rapport de laboratoire : un exemple
9
© Département de physique, Cégep de Sherbrooke, 2006
•
Cliquer sur «Terminer ». Une nouvelle feuille nommée « Graph1 » est crée. On peut basculer
de la feuille de calcul « Feuil1 » au graphique en cliquant sur l’onglet approprié au bas de
l’écran.
•
Dans
la
feuille
« Graph1 »,
la
barre
d’outils
« Graphique » devrait apparaître. Sinon, il suffit de
cliquer sur le bouton droit de la souris dans la région
des barres d’outils (par exemple sur le bouton
d’impression) afin d’afficher le menu des barres
d’outils. Un crochet apparaît à côté des barres
d’outils actives. On peut activer ou désactiver la
barre d’outils « Graphique » en cliquant sur le mot
« Graphique ». On peut ensuite la déplacer si elle
cache quelque chose (elle sera très utile).
Utilisation d’Excel dans un rapport de laboratoire : un exemple
10
© Département de physique, Cégep de Sherbrooke, 2006
Mise en forme générale du graphique
•
Dans la barre d’outils, sélectionner« Zone de traçage » et cliquer sur le bouton
. Dans la
section « Aires », choisir « Blanc » et cliquer sur « ok » afin d’enlever le fond gris et éviter
un gaspillage d’encre.
•
Note : pour modifier une chose, on peut facilement la sélectionner en cliquant dessus et en
appuyant sur le bouton droit de la souris pour un menu d’options (ou cliquer sur
). Étant
donné le nombre d’items dans un graphique, il est souvent difficile de sélectionner la
« bonne » chose. On procède alors avec le menu déroulant de la barre d’outils.
•
Sélectionner le titre de l’axe des ordonnées (Y). Cliquer ensuite sur ce titre pour l’éditer.
Sélectionner le « t », appuyer sur le bouton droit de la souris et cliquer sur « Format du titre
du graphique ». Il suffit de cocher l’attribut « Indice » dans la boîte de dialogue. C’est ici
qu’on peut changer la police de caractères pour accéder aux lettres grecques (Symbol) par
exemple. On peut également utiliser une police italique pour les variables.
Utilisation d’Excel dans un rapport de laboratoire : un exemple
11
© Département de physique, Cégep de Sherbrooke, 2006
Correction du quadrillage du graphique
•
Sélectionner le quadrillage secondaire de l’axe Y et cliquer sur le bouton
. Dans l’onglet
« Echelle », fixée la valeur minimale à 300. Diminuer les unités principale et secondaire à 50
et 5 (par exemple) pour un quadrillage plus fin (le quadrillage doit approcher un papier
millimétrique).
•
De la même façon, réduire l’unité secondaire de l’axe X à 0,5.
•
Sélectionner le quadrillage principal de l’axe Y et cliquer sur le bouton
. Dans l’onglet
« Motifs », choisir un trait légèrement plus large (le deuxième), afin de distinguer les
graduations principales. Répéter pour l’axe X. Pour le quadrillage secondaire, utiliser le trait
le plus fin. Avec une imprimante couleur, on peut également donner une couleur plus pâle au
quadrillage secondaire.
•
Bogue : l’option quadrillage secondaire de l’axe Y de la barre d’outils sélectionne en fait le
quadrillage principal. On le voit avec les petits carrés noirs sur les graduations principales de
l’axe Y. Pour vraiment sélectionner le quadrillage secondaire, il est nécessaire de cliquer sur
l’axe vertical de manière à avoir des petits carrés noirs un peu partout sur l’axe Y.
•
Sélectionner l’axe des ordonnées (X) et cliquer sur le bouton
. Dans l’onglet « Nombre »,
ajuster le nombre de décimales à 0. En effet, la graduation des axes ne devrait pas inclure de
chiffre inutile.
Utilisation d’Excel dans un rapport de laboratoire : un exemple
12
© Département de physique, Cégep de Sherbrooke, 2006
Voici le graphique obtenu. Pour ajouter un numéro, il suffit d’éditer le titre principal.
Ajout des barres d’incertitudes
•
Cliquer sur un point du graphique (Sélectionner la série de données). Cliquer sur le bouton
ou passer par le menu du bouton droit de la souris.
•
Dans l’onglet « Barre d’erreur X »,
choisir le motif « Les deux ». Choisir
la marge d’erreur personnalisée et
appuyer sur le bouton au bout de la
ligne pour l’incertitude « + ».
Basculer dans la feuille de calcul et
sélectionner les cellules E6 à E13.
Cliquer à nouveau sur le bouton pour
afficher la boîte de dialogue en entier.
Répéter pour l’incertitude « - ».
Utilisation d’Excel dans un rapport de laboratoire : un exemple
13
© Département de physique, Cégep de Sherbrooke, 2006
•
Dans l’onglet « Barre d’erreur Y », choisir le motif « Les deux » et la marge d’erreur de type
« Précision ». Entrer dans la case correspondante une précision de 0,1.
•
Cliquer sur « ok ».
•
Les barres d’incertitudes sont
crées mais les marque
verticales sont erronées
(défaut de Excel).
Sélectionner une barre
d’erreur et cliquer sur le
bouton
. Dans l’onglet
« Motif », sélectionner la
marque simple (à droite), ce
qui donnera des croix comme
barres d’erreurs. Comme
l’incertitude sur les masses
est très faible ici, elle
n’apparaît pas sur le
graphique (et c’est correct!).
•
Choisir lorsque nécessaire le 3e trait pour les barres d’incertitude (plus épais que le quadrillage
principal) afin qu’elles soient bien visibles.
Ajout de la courbe de tendance
•
Cliquer sur un point du
graphique. Cliquer sur le
bouton droit de la souris et
sur « Ajouter une courbe de
tendance ».
•
Dans l’onglet « Type »,
choisir « Linéaire » puisqu’il
y a en principe une relation
linéaire entre la masse et le
volume à densité constante.
•
Dans l’onglet « Options »,
cocher la case « Afficher
l’équation sur le graphique »,
puis sur « ok ».
•
Sélectionner et déplacer ensuite l’équation à un endroit convenable et cliquer sur
. Dans
l’onglet « Motifs », on peut ajouter une bordure ainsi qu’une aire blanche.
Utilisation d’Excel dans un rapport de laboratoire : un exemple
14
© Département de physique, Cégep de Sherbrooke, 2006
Impression du graphique dans Excel
•
Choisir l’option « Mise en page » du menu « Fichier ».
•
Dans l’onglet « Page », utiliser l’orientation « Paysage » et une qualité d’impression de 600
ppp.
•
Dans l’onglet « Marges », réduire les 4 marges à 0,5 afin de maximiser l’utilisation de la
page.
Le graphique final est imprimé à la page suivante. On a obtenu une pente de 9,62. La densité est
donc 0,962 g/cm³, soit 962 kg/m³.
Utilisation d’Excel dans un rapport de laboratoire : un exemple
15
© Département de physique, Cégep de Sherbrooke, 2006
Graphique 1
Masse mesurée en fonction du volume d'eau
700
650
y = 9,6235x + 341,61
600
mt (g)
550
500
450
400
350
300
0
5
10
15
20
25
30
35
40
V X 10 (cm³)
16
© Département de physique, Cégep de Sherbrooke, 2006
Points à surveiller concernant les graphiques
Présentation de base
•
Le graphique est numéroté dans sa partie supérieure, sauf s’il n’y a qu’un seul graphique.
•
Le graphique possède un titre en toutes lettres dans sa partie supérieure.
•
Les axes sont identifiés par le nom de la variable ou le même symbole de variable que celui
utilisé dans le tableau et dans le reste du rapport.
•
Les unités apparaissent entre parenthèses.
•
Le graphique imprimé (au laser ou qualité comparable) occupe toute la page.
•
La légende n’est affichée que si elle est utile (plusieurs séries de données).
•
Le fond grisé du graphique (qu’Excel choisit par défaut) a été supprimé (zone de traçage).
•
Le type de graphique choisi est habituellement « nuage de points » (sans courbe) auquel on
ajoute une courbe de tendance. Voir la page 29 si on ne veut qu’une courbe (lissée) qui passe
par les points (sans équation).
Graduations
•
Les quadrillages principal et secondaire sont activés pour les deux axes.
•
Une couleur différente ou un trait plus large est choisi pour le quadrillage principal.
•
Les unités principales et secondaires (graduation) sont des multiples décimaux de 1,2 ou 5.
•
Les unités secondaires sont choisies de manière à produire un quadrillage s’approchant d’un
papier millimétrique.
•
La graduation est choisie de manière à exploiter le mieux possible l’espace disponible.
•
Les nombres sur les axes possèdent seulement le nombre de chiffres significatifs requis pour la
graduation. Les décimales supplémentaires sont supprimées.
Courbe de tendance (s’il y a lieu)
•
Un modèle physique appuie le choix du type de courbe de tendance (sinon on n’en met pas).
•
L’équation obtenue par Excel apparaît sur le graphique.
•
La courbe de tendance a été obtenue en négligeant les éventuels points singuliers, bien que ces
derniers apparaissent sur le graphique (voir la page 29 pour ce traitement spécial).
Marques d’incertitudes (s’il y a lieu)
•
Le motif des barres d’incertitudes a été changé pour la croix (Guide des sciences
expérimentales, fig 3.8 p.97 et fig. 3.11 p.98), car le motif par défaut conduit à des
interprétations erronées.
•
Les barres d’incertitudes sont visibles sur le quadrillage (sinon choisir un trait plus épais).
•
Le professeur pourra demander de tracer à la main les droites extrêmes afin de calculer
l’incertitude sur la pente. Ces tracés devront être fins pour qu’il ne prennent pas une
importance visuelle plus grande que le tracé de la courbe expérimentale.
Points à surveiller concernant les graphiques
17
© Département de physique, Cégep de Sherbrooke, 2006
Mise en forme des tableaux
Deux options sont offertes.
1.
Formater le tableau dans Excel pour ensuite l’intégrer au rapport de laboratoire (document
Word)
2.
Travailler sans mise en forme dans Excel pour réaliser les graphiques. Ensuite, sélectionner,
copier et coller les données brutes dans Word pour finalement formater le tableau dans Word.
La première option est recommandée et est présentée ici. Noter cependant qu’il est essentiel dans
un rapport de laboratoire d’incorporer le tableau au document Word afin de préserver la fluidité
du texte.
Mise en forme dans Excel
Le tableau de la page 6 est repris ici comme point de départ. Les étapes suivantes sont réalisées
facilement, sans recourir aux menus d’Excel (Guide des sciences expérimentales p.87-88)
•
Ajouter une décimale à certaines cellules à l’aide du bouton
.
•
Centrer les cellules de la colonne D et F à l ‘aide du bouton
.
•
Aligner à gauche les cellules de la colonne E à l’aide du bouton
•
Ajout de bordures (cadre complet) pour 4 groupes de
.
cellules (C6 à E13, F6 à F13, C3 à E5 et C4 à E4).
•
Ajout de bordures (quadrillage) pour les cellules F3 à
F5.
•
Réduire adéquatement la taille des colonnes, en
particulier la colonne D.
•
Utiliser le bouton « Fusionner et centrer »
pour les
cellules A1 à H1, puis pour A2 à H2.
Aussi, il est d’usage (surtout lorsque le document contient des équations) de choisir une police de
caractères italique pour les symboles (la ligne 4 ici). Pour une présentation parfaite, choisir la
même police dans Word (Times New Roman par défaut) et dans Excel (Arial par défaut) de
manière à ce que les symboles dans les tableaux aient la même apparence que ceux dans le texte.
Ici, on a laissé Arial dans Excel ce qui suppose que la police Arial sera choisie dans Word (et
éventuellement dans l’éditeur d’équations).
On ajoute la définition des symboles, ce qui donne le résultat présenté à la page suivante:
Mise en forme des tableaux
18
© Département de physique, Cégep de Sherbrooke, 2006
Copier correctement un tableau ou un graphique Excel dans Word
La fonction copier / coller fonctionne toujours mais ne conserve pas la mise en forme. Le remède
consiste à utiliser l’option « Collage spécial » du menu édition de Word au lieu de « Coller ».
Voici la procédure (voir la page écran de la page suivante):
•
Sélectionner les cellules pertinentes (ou le graphique en entier) dans Excel et cliquer sur le
bouton
.
•
Dans Word, choisir l’option « Collage spécial » du menu Édition.
•
Choisir de coller en tant que feuille de calcul (ou graphique) Microsoft Excel Objet.
•
Il est même possible de lier vos deux documents à l’aide de l’option « Coller avec liaison ».
Ceci veut dire que l’objet (tableau ou graphique) sera automatiquement mis à jour dans
Word s’il est modifié dans Excel (wow!); mais dans ce cas, il faudra faire la mise en forme du
tableau dans word et non dans Excel!
Mise en forme des tableaux
19
© Département de physique, Cégep de Sherbrooke, 2006
Le tableau une fois intégré dans Word :
Tableau 1
Masses mesurées en fonction du volume d'eau
V
10 cm³
4,0
8,0
12,0
16,0
20
24
28
32
±
±
±
±
±
±
±
±
0,2
0,4
0,6
0,8
1
1
1
2
mt
g
± 0,1
380,2
418,2
457,1
496,0
534,0
572,7
611,2
649,3
V : volume d'eau dans le récipient
m t : masse totale (eau et récipient)
Mise en forme des tableaux
20
© Département de physique, Cégep de Sherbrooke, 2006
Exemple sur le calcul d'incertitude avec Excel
Il est souvent avantageux d'utiliser Excel pour le calcul des incertitudes sur vos données plutôt
que de le faire à la main. L'exemple qui suit est un calcul d'incertitude fait sur un logarithme. Ce
type de calcul revient très souvent c'est pourquoi nous l'avons choisi.
Mise en situation :
Dans le cours d'électricité et magnétisme on désire caractériser un condensateur. Pour ce faire, on
mesure le voltage V aux bornes du condensateur pendant la décharge de celui-ci. Pour obtenir
l'information qui nous intéresse on doit faire le graphique du logarithme naturel du voltage, soit
ln(V), en fonction du temps t. Ici, connaissant V et son incertitude nous allons calculer ln(V) et
son incertitude.
Calcul d’une fonction mathématique
Lorsque vous cherchez le nom d'une fonction dans Excel vous pouvez cliquer sur l'icône
dans
la barre d'outils. Il apparaît alors une liste de fonction séparée en catégories. En choisissant une
fonction, vous obtenez une description de la fonction ainsi que la syntaxe qu'il faut utiliser.
Exemple sur le calcul d'incertitude avec Excel
21
© Département de physique, Cégep de Sherbrooke, 2006
Calcul de l'incertitude sur une fonction
Dans la colonne C on retrouve les mesures brutes de voltages avec leurs incertitudes dans la
colonne D. Notez qu’ici aucun effort n’a été déployé pour le mise en forme du tableau; cette étape
serait réalisée ultérieurement. Dans la colonne E la valeur du logarithme de V est calculée alors
que dans la colonne F c’est plutôt l’incertitude sur ln(V) qui est calculée par la méthode des
extrêmes.
La cellule E7 a été obtenue en écrivant l'équation suivante : =ln(C7). La fonction ln dans Excel
permet de calculer le logarithme naturel d'un nombre; ici le nombre est la valeur contenue dans la
cellule C7. C'est dans la cellule F7 qu'est fait le calcul d'incertitude sur le ln(V); la méthode des
extrêmes a été utilisée. Regardons de plus près la formule de la cellule H7 :
=(LN(C7+D7)-LN(C7-D7))/2
Le premier terme LN(C7+D7) correspond à la valeur maximale que peut prendre ln(V) soit
ln(V+∆V). Alors que le terme LN(C7-D7) correspond à la valeur minimale de ln(V). La différence
entre ces deux termes divisée par 2 nous donne finalement l'incertitude sur ln(V).
Exemple sur le calcul d'incertitude avec Excel
22
© Département de physique, Cégep de Sherbrooke, 2006
Écriture des équations avec Mathtype (dans Word)
L'utilisation d'un logiciel de traitement de texte pour la rédaction d'un rapport de laboratoire est
incontournable. La plupart des gens ont une connaissance de base dans l'utilisation du traitement
de texte. Ce que nous vous proposons ici c'est de résumer un aspect souvent méconnu du
traitement de texte: l'utilisation d'un éditeur d'équation.
Au Cégep de Sherbrooke vous avez accès au logiciel MathType (version 5.0) directement à partir
de Word. Ce logiciel est spécialement dédié à l'écriture d'équations mathématiques. En cliquant
sur le bouton
dans Word, vous lancez le logiciel MathType et la fenêtre suivante devrait
apparaître :
Si vous n'avez pas MathType à la maison, sachez que Word offre par défaut un éditeur d'équation
qui est en fait un sous-produit de MathType. Ce logiciel fonctionne de la même manière que
MathType mais offre moins de symboles de fonctionnalités. On y accède dans le menu
Insertion/Objet, et en choisissant « Équation Microsoft … ». Si nécessaire, vous devrez l’installer
à l’aide du CD d’installation de Microsoft Office.
Écriture des équations avec Mathtype (dans Word)
23
© Département de physique, Cégep de Sherbrooke, 2006
En explorant, vous découvrirez que chaque bouton contient une panoplie de symboles. Essayez
d'écrire l'équation suivante :
1G
G
G G
x = x 0 + v 0t + at 2
2
Une fois que vous avez fini d'écrire l'équation dans MathType, allez dans le menu Fichier et
choisissez : Fermer et retourner…ou tapez directement « CTRL+F4 ». Cette commande va
automatiquement insérer votre équation dans Word et fermer le logiciel MathType. Si vous
voulez modifier une équation déjà existante dans Word vous n'avez qu'à faire un double clique sur
l'équation que vous voulez modifier et MathType va automatiquement s'ouvrir avec votre
équation. Faites-les corrections nécessaires et appuyez sur CTRL+F4 afin de revenir dans Word
avec votre nouvelle équation modifiée.
Écriture des équations avec Mathtype (dans Word)
24
© Département de physique, Cégep de Sherbrooke, 2006
Trucs et astuces sur Word et Excel
Courbe de tendance passant par (0,0) dans Excel
Il peut être judicieux de forcer Excel à trouver une droite de tendance qui coupe l’axe horizontal à
0. Ceci se présente à chaque fois qu’on veut vérifier un modèle théorique dont l’ordonnée à
l’origine est 0 (2e loi de Newton, loi d’Ohm, etc.). Il suffit d’activer l’option « Coupe l’axe
horizontal à » et de spécifier la valeur 0 au moment d’insérer la courbe de tendance. Si la courbe
est déjà là, accéder à l’onglet « Options » de la boîte de dialogue « Format de courbe de
tendance », en sélectionnant et formatant la courbe de tendance.
Prolongation de la courbe de tendance dans Excel
Par défaut Excel trace une courbe de tendance entre les points expérimentaux, sans
nécessairement rejoindre les extrémités de la zone de graphique. On peut le forcer à prolonger la
courbe de tendance à l’aide des options « Prospective » et « Rétrospective » de la boîte de
dialogue ci-haut (Format de la courbe de tendance). Le nombre d’unités correspond à la variation
de la variable X nécessaire pour allonger la courbe vers la gauche (rétrospective) ou vers la droite
(prospective).
Trucs et astuces sur Word et Excel
25
© Département de physique, Cégep de Sherbrooke, 2006
Traitement des pentes extrêmes avec Excel
Il s’agit ici d’utiliser Excel pour tracer les pentes extrêmes et de calculer l’incertitude sur la pente.
La méthode utilisée ici est celle suggérée par le Guide des Sciences expérimentales de Boisclair et
Pagé, section 4.5.1, p.143; en aucun cas ces démarches devraient remplacer le jugement (voir le
commentaire à la fin de cette partie). Nous allons illustrer la démarche avec notre exemple
précédent que l’on retrouve à la page Erreur ! Source du renvoi introuvable.. En voici les
principales étapes :
-
Choisir deux points arbitraires qui appartiennent à la droite. Ici nous avons choisi
V1 = 4,5 × 101 cm3 et V2 = 31×101 cm3 . Pour trouver l’ordonnée de ces points, il suffit
d’utiliser l’équation de la droite obtenue par régression linéaire y = 9, 6235 x + 341, 61 .
Aussi, on associe à ces points l’incertitude du point le plus près. Nous obtenons donc les
coordonnées des deux points :
-
V1 = ( 4,5 ± 0, 2 ) × 101 cm3
V2 = ( 31 ± 2 ) × 101 cm3
m1 = ( 384,9 ± 0,1) g
m2 = ( 639,9 ± 0,1) g
Illustrer ces points sur le graphique en créant une nouvelle série. Utiliser un trait en
pointillés avec une couleur différente afin d’illustrer clairement que ces points ne font pas
partie des données expérimentales. Pour ajouter une nouvelle série, aller dans le menu
« Graphique » et choisir « Données source » puis choisir « Ajouter ». Indiquer les
valeurs en X et Y tel que mentionné précédemment à la page 8.
Trucs et astuces sur Word et Excel
26
© Département de physique, Cégep de Sherbrooke, 2006
-
Il faut maintenant tracer deux droites : une pour la pente max et une deuxième pour la
pente min. Les droites sont définies par les limites extérieures des rectangles formées par
les points arbitraires choisis précédemment. Dans notre cas les coordonnées des points
sont les suivants :
Pour la pente max :
Pour la pente min :
-
Vmax1 = 4, 7 × 101 cm3
mmax1 = 384,8 g
Vmin1 = 4,3 ×101 cm3
mmin1 = 385, 0 g
et
et
Vmax 2 = 29 ×101 cm3
mmax 2 = 640, 0 g
Vmin 2 = 33 × 101 cm3
mmin 2 = 639,8 g
Pour tracer les droites des pentes max et min vous devez créer pour chaque cas une
nouvelle série. Choisir un trait de forme et/ou de couleur différente afin de discerner ces
droites de la meilleure droite.
-
Au besoin et selon votre jugement, vous modifiez l’inclinaison des droites extrêmes en
déplaçant, avec la sourie directement sur le graphique, les points qui servent à définir ces
droites.
-
Pour le calcul des pentes max, min ainsi que de l’incertitude sur la pente, vous procédez
par calcul (dans Excel, pourquoi pas!) et non graphiquement.
Remarque : si vous regarder les droites extrêmes telles que choisies par défaut (méthode Boisclair
et Pagé) vous remarquerez que les pentes extrêmes sont légèrement sur-évaluées car il y a au
moins deux points qui ne sont pas touchés par les pentes extrêmes. Cet exemple nous démontre
justement qu’il faut toujours se servir de son jugement et que la méthode de Boisclair et Pagé est
une bonne méthode pour amorcer l’analyse. Dans cet exemple, le résultat obtenu pourrait être :
ρ = 0,96 ± 0, 06 g / cm3
Le nouveau « graphique 1 » (amélioré!) est illustré à la page suivante.
Trucs et astuces sur Word et Excel
27
© Département de physique, Cégep de Sherbrooke, 2006
Graphique 1
Masse mesurée en fonction du volume d'eau
700
650
y = 9,6235x + 341,61
600
mt (g)
550
500
450
400
350
300
0
5
10
15
20
25
30
35
40
V X 10 (cm³)
Trucs et astuces sur Word et Excel
28
© Département de physique, Cégep de Sherbrooke, 2006
Points singuliers : quoi faire ?
Il arrive parfois, parmi les mesures effectuées, que l’on retrouve un ou plusieurs points singuliers. L’origine
d’un point singulier est souvent associée à un mauvais fonctionnement d’un appareil ou à une erreur de
lecture. Si vous tracez la régression linéaire sur une série de points qui contient un point singulier, le
résultat obtenu sera non représentatif de l’ensemble de vos « bonnes » mesures. Pour éviter ce problème,
il s’agit simplement de créer deux séries de points : l’une contenant les « bonnes » mesures et l’autre le
ou les points singuliers. Lorsque vous faites la régression linéaire, vous la faites seulement sur la série qui
contient les « bonnes » mesures; tous les points seront affichés sur le graphiques mais l’équation de la
droite obtenue par régression ne tiendra pas compte des points singuliers.
Lissage de courbe
Excel offre six types de courbes de tendance : linéaire, logarithmique, polynomiale, puissance,
exponentielle et moyenne mobile.
Trucs et astuces sur Word et Excel
29
© Département de physique, Cégep de Sherbrooke, 2006
Que fait-on si la relation entre deux mesures ne peut s’exprimer selon un de ces six types de courbe de
tendance ? Dans certains cas, on peut « linéariser » les relations avec les logarithmes. Plus généralement,
on peut simplement demander une courbe lissée. Prenons à titre d’exemple, la charge d’un condensateur :
si on place un condensateur en série avec une source DC et une résistance R, le voltage aux bornes d’un
condensateur C lorsqu’il se charge, varie de la manière suivante :
Vc = Vo (1 − e − t RC )
Si on fait un graphique du voltage (mesuré) en fonction du temps, on ne pourra pas faire une régression
directement avec Excel puisqu’il ne supporte pas ce genre de fonction et que le voltage maximum (Vo)
n‘est pas toujours bien connu. Si on a plusieurs mesures, il est possible d’utiliser un lissage de courbe. Il
s’agit simplement de sélectionner l’onglet « Motifs » dans « Format de série de données » et de cocher
« Lissage » pour le trait. Avec beaucoup de points (comme c’est le cas dans notre exemple), on doit aussi
choisir une taille des points (marques) assez petite.
Alternativement, on peut changer le type de graphique pour « Nuage de points reliés par une courbe
lissée » ou encore « Nuage de points avec lissage sans marquage des données ». Le résultat graphique est
présenté à la page suivante :
Trucs et astuces sur Word et Excel
30
© Département de physique, Cégep de Sherbrooke, 2006
Graphique 2
Voltage aux bornes d'un condensateur en fontion du temps lors de la charge
9
8
7
Vc (V)
6
5
4
3
2
1
0
0,0
0,1
0,2
0,3
t (s)
Trucs et astuces sur Word et Excel
31
© Département de physique, Cégep de Sherbrooke, 2006
Comparaison des résultats
La troisième édition du Guide des sciences expérimentales de Boisclair et Pagé vient avec un CDROM sur lequel se retrouve (entre autre) un fichier nommé comparaison.xls. Ce fichier peut être
utilisé afin d’illustrer la comparaison entre deux résultats. Cette comparaison devrait se retrouvée
dans la section Discussion de votre rapport de laboratoire. Pour ce faire, utiliser le fichier
comparaison.xls et changer les titres, les données numériques, leur incertitude et les unités. Le
fichier comparaison.doc vous explique comment utiliser le fichier comparaison.xls.
Ensuite, vous copiez le graphique obtenu dans votre document word avec le collage spécial (voir
page 19). Voici un exemple d’utilisation de ce fichier :
Masse volumique expérimentale ( 960 ± 6 ) kg/m³
Masse volumique prédite ( 965 ± 3 ) kg/m³
950
955
960
965
970
kg/m³
Sauvegarde régulière
Il est chaudement recommandé de sauvegarder régulièrement (aux 5 minutes) son travail sur son
espace réseau (t:\document par exemple). Pour sauvegarder pour pouvez utiliser directement les
touches CTRL+S.
Recyclage des fichiers
Au lieu de recommencer à zéro à chaque laboratoire, on peut gagner du temps à utiliser un fichier
précédent pour en modifier les données. Ainsi, on peut par exemple obtenir un nouveau graphique
en un rien de temps à partir d’un document existant.
Trucs et astuces sur Word et Excel
32
© Département de physique, Cégep de Sherbrooke, 2006
Alphabet grec et caractères spéciaux dans Word et Excel
L'option « Caractères spéciaux » du menu Insertion du logiciel Word est bien connue. Elle
permet d'accéder facilement aux caractères de la police « Symbol », « MT Extra » et autres.
Malheureusement, il n’existe pas l’équivalent dans Excel. Il est tout de même possible d’afficher
tous les symboles voulus, que ce soit dans un tableau ou un graphique.
Alphabet grec dans Excel
Pour accéder à un caractères grec (par exemple α), il faut d’abord connaître son équivalent dans
l’alphabet romain (ici a). Toutes ces équivalences sont données au tableau de la page suivante
(gracieuseté de Laurier St-Amant). Attention à la casse. Par exemple, le symbole Σ correspond à
S (majuscule) tandis que le symbole σ correspond à s (minuscule). Voici les étapes à suivre dans
Excel :
•
Taper le caractère romain correspondant (dans la cellule Excel ou la zone de texte d’un
graphique)
•
Sélectionner ce caractère à l’aide de la souris
•
Changer la police (Arial par défaut) pour la police « Symbol »
Caractères spéciaux
La plupart des autres caractères spéciaux (±, °, etc.) s’obtiennent directement dans tout logiciel
au moyen d’une combinaison de touches (voir la deuxième partie du tableau de la page suivante).
Noter qu’il n’est pas absolument nécessaire d’utiliser la police « Times New Roman »; toute
police de caractères romains fonctionne (par exemple « Arial »). Par exemple, pour afficher le
symbole des degrés (°), il suffit de maintenir la touche « Alt » enfoncée et de taper la séquence
0186 à l’aide du clavier numérique (extrême droite du clavier). D’autre exemples ont été
rencontrés dans ce document (voir page 6). Certains caractères, comme le symbole infini (∞)
demandent en plus de changer la police de caractères pour la police « Symbol », après avoir tapé
la séquence de caractères appropriée. Dernière remarque : la touche « Alt » s’utilise avec le
clavier numérique alors que la touche « Alt Car » s’utilise avec le clavier standard.
Trucs et astuces sur Word et Excel
33
© Département de physique, Cégep de Sherbrooke, 2006
Alphabet grec et caractères spéciaux utilisés avec Windows
Appellation
Alpha
Bêta
Gamma
Delta
Epsilon
Zêta
Êta
Thêta
Iota
Kappa
Lambda
Mu
Nu
Xi
Omicron
Pi
Rhô
Sigma
Tau
Upsilon
Phi
Khi
Psi
Oméga
Appellation
Minuscule
α
β
γ
δ
ε
ζ
η
θ
ι
κ
λ
µ
ν
ξ
ο
π
ρ
σ
τ
υ
φ (ou ϕ)
χ
ψ
ω
Apparence
Alphabet grec
Majuscule
Α
Β
Γ
∆
Ε
Ζ
Η
Θ
Ι
Κ
Λ
Μ
Ν
Ξ
Ο
Π
Ρ
Σ
Τ
Υ
Φ
Ξ
Ψ
Ω
Accès au clavier
avec la police
Symbol
A
B
G
D
E
Z
H
Q
I
K
L
M
N
X
O
P
R
S
T
U
F (ou j)
X
Y
W
Caractères spéciaux
Exemple
Accès au clavier
avec la police
Symbol
Ex. 10 ºC
Accès au clavier
avec la police
Times New Roman
AltCar et m
Accès au clavier
avec la police
Times New Roman
Alt et 0186
Degré
º
Point au centre
·
Infini
∞
Alt et 0165
N’égale pas
≠
Alt et 0185
À peu près égal à
≅
AltCar et 2
Tilde
∼
Flèche à droite
→
Implication
=>
= et >
Plus ou moins
±
AltCar et 1
Exposant 2
²
AltCar et 8
Exposant 3
³
AltCar et 9
Une demie
½
AltCar et -
Un quart
¼
AltCar et 0
Trucs et astuces sur Word et Excel
Alt et 0183
Ex. N·m
AltCar et ;
/~phy
Alt et 0174
34

Documents pareils

Utilisation de l`ordinateur dans la rédaction des rapports

Utilisation de l`ordinateur dans la rédaction des rapports un récipient) en fonction de son volume. Si la masse volumique est constante au cours de l’expérience, la relation entre la masse et le volume devrait être linéaire. L’exemple est construit à l’aid...

Plus en détail